BaaS - Repo Upgrade
Incident Report for AllConnected
Resolved
This incident has been resolved.
Posted Jan 28, 2019 - 17:51 PST
Monitoring
A critical security patch was deemed necessary and implemented.
Posted Jan 28, 2019 - 17:50 PST
This incident affected: Backups as a Service (B.a.a.S) (BaaS Backup Data Repository).